import re
regex = re.compile(r"^(?=.{10,255}$)(?=.{4,64}@)[A-z0-9]+(?:[.-][A-z0-9]+)*@[A-z0-9]+(?:[.-][A-z0-9]+)*\.[A-z]+$", flags=re.MULTILINE | re.UNICODE)
test_str = ("a-b.de@fn.cdpdodo\n\n"
"-abde@fn.co\n"
"_abde@_fn.co\n"
".abde@fn.co\n"
"abde_@fn.co\n"
"ab_de@_f------n.co\n\n"
"abdسيبe@fn.co\n"
"abde@fn.co\n"
"ab_nnnn___0---....................-----de@fn.f.co\n"
"abde@.fn.f.co\n"
".......abde@fn.f.co\n"
"fkb-----kkkabde@fn.f.co\n"
"f3.f3.f3.f3.fff3@gmail.com\n"
"qowijdoqiwjdoqwi@coeoicmoei.ecpomep.d.docimequo\n"
"a23456789a123456789b123456789c123456789d123456789e123456789f1234@ex.com\n"
"a23456789a123456789b123456789c123456789d123456789e123456789f12345@ex.com \n\n"
"wijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwij@coeo444--icmoei.ecpomepocime\n\n"
"wijdoqiwjdoqwij@coeo444--icmoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecpomepocime\n\n"
"wijdoqiwjdoqwij@coeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmoei.ecpomepocime\n\n"
"wijdoqiwjdoqwij@coeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmoei.ecpomepocimeecpomepocimeecpomepocimeecpomepocimeecpomepocimeecpomepocimeecpomepocime\n\n"
"[\\w.-]{2,}\\.[A-z]{2,}\n"
"^[A-z0-9][\\w.-]{0,64}[A-z0-9]@(?:[A-z0-9-]{1,63}\\.){1,3}[A-z]{2,63}$")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")