import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"^(?=.{10,255}$)(?=.{4,64}@)[A-z0-9]+(?:[.-][A-z0-9]+)*@[A-z0-9]+(?:[.-][A-z0-9]+)*\.[A-z]+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
a-b.de@fn.cdpdodo
-abde@fn.co
_abde@_fn.co
.abde@fn.co
abde_@fn.co
ab_de@_f------n.co
abdسيبe@fn.co
abde@fn.co
ab_nnnn___0---....................-----de@fn.f.co
abde@.fn.f.co
.......abde@fn.f.co
fkb-----kkkabde@fn.f.co
f3.f3.f3.f3.fff3@gmail.com
qowijdoqiwjdoqwi@coeoicmoei.ecpomep.d.docimequo
a23456789a123456789b123456789c123456789d123456789e123456789f1234@ex.com
a23456789a123456789b123456789c123456789d123456789e123456789f12345@ex.com
wijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwij@coeo444--icmoei.ecpomepocime
wijdoqiwjdoqwij@coeo444--icmoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecpomepocime
wijdoqiwjdoqwij@coeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmoei.ecpomepocime
wijdoqiwjdoqwij@coeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmoei.ecpomepocimeecpomepocimeecpomepocimeecpomepocimeecpomepocimeecpomepocimeecpomepocime
[\w.-]{2,}\.[A-z]{2,}
^[A-z0-9][\w.-]{0,64}[A-z0-9]@(?:[A-z0-9-]{1,63}\.){1,3}[A-z]{2,63}$
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)