$re = '/Hello I am (?:really )?him\./';
$str = 'Hello I am really him.
Hello I am him.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);