re = /Hello I am (?:really )?him\./
str = 'Hello I am really him.
Hello I am him.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end