using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(\w+)";
string input = @"<a>This is a link</a>
<a href='https://regexone.com'>Link</a>
<div class='test_style'>Test</div>
<div>Hello <span>world</span></div>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}