$re = '/<(\w+)/m';
$str = '<a>This is a link</a>
<a href=\'https://regexone.com\'>Link</a>
<div class=\'test_style\'>Test</div>
<div>Hello <span>world</span></div>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);