const regex = /<(\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(\\w+)', 'gm')
const str = `<a>This is a link</a>
<a href='https://regexone.com'>Link</a>
<div class='test_style'>Test</div>
<div>Hello <span>world</span></div>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}