const regex = /^(?=\S.+\nCoverage\sLevel)|^(?=\S.+\nNon-Covered\s)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=\\S.+\\nCoverage\\sLevel)|^(?=\\S.+\\nNon-Covered\\s)', 'gm')
const str = `Out of Pocket (Stop Loss)
Coverage Level: Individual
Service Type: Health Benefit Plan Coverage
Insurance Type Code: HM Health Maintenance Organization (HMO)
Time Period Qualifier: Calendar Year
Amount: \$8,500.00
In Plan Network Indicator: Unknown
Deductible
Coverage Level: Individual
Service Type: Vision (Optometry)
https://luna.ema.md/ema/patient/InsuranceOverviewForm.action?pic1.0u85-w2bBh0R86_K9v71KolpMN1sZmZ0Lxolu1TW4qD3al-JJFDVNX81... 13/172/21/22, 10:26 AM Luna Dermatology: Patient Insurance
Insurance Type Code: HM Health Maintenance Organization (HMO)
Plan Coverage Description: Fidelis Care Silver
Amount: \$0.00
Authorization/Certification Req'd: No
In Plan Network Indicator: no
Co-Payment
Coverage Level: Individual
Service Type: Vision (Optometry)
Insurance Type Code: HM Health Maintenance Organization (HMO)
Plan Coverage Description: Fidelis Care Silver
Amount: \$0.00
Authorization/Certification Req'd: No
In Plan Network Indicator: Yes
Co-Insurance
Coverage Level: Individual
Service Type: Vision (Optometry)
Insurance Type Code: HM Health Maintenance Organization (HMO)
Plan Coverage Description: Fidelis Care Silver
Authorization/Certification Req'd: No
In Plan Network Indicator: Unknown
Out of Pocket (Stop Loss)
Coverage Level: Family
Service Type: Health Benefit Plan Coverage
Insurance Type Code: HM Health Maintenance Organization (HMO)
Time Period Qualifier: Remaining
Amount: \$16,190.82
In Plan Network Indicator: Unknown
Non-Covered
Coverage Level: Individual
Service Type: Medical Care
Insurance Type Code: HM Health Maintenance Organization (HMO)
Plan Coverage Description: Fidelis Care Silver
In Plan Network Indicator: No
Message: Medical Care
Non-Covered
Coverage Level: Individual
Service Type: Durable Medical Equipment Purchase
Insurance Type Code: HM Health Maintenance Organization (HMO)
Plan Coverage Description: Fidelis Care Silver
In Plan Network Indicator: No
Message: DME Purchase`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);