#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[1-9]\d{0,3}(?:\.\d{1,2})?$"
Local $sString = "10000" & @CRLF & _
"999.99" & @CRLF & _
"11" & @CRLF & _
"333.1" & @CRLF & _
"1" & @CRLF & _
"0" & @CRLF & _
"10000" & @CRLF & _
"9999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")