re = /^[1-9]\d{0,3}(?:\.\d{1,2})?$/m
str = '10000
999.99
11
333.1
1
0
10000
9999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end