$re = '/^[1-9]\d{0,3}(?:\.\d{1,2})?$/m';
$str = '10000
999.99
11
333.1
1
0
10000
9999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);