import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\w_-]+)\\.(?:m\\.)?wikipedia.org/(((?!([\\\"'<])).)*)";
final String string = "https://en.m.wikipedia.org/wiki/DNS_over_TLS\n"
+ "https://en.wikipedia.org/wiki/DNS_over_TLS\n"
+ "en.m.wikipedia.org/wiki/DNS_over_TLS\n"
+ "en.wikipedia.org/wiki/DNS_over_TLS";
final String subst = "wikiless.org/$2&lang=$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}