re = /([\w_-]+)\.(?:m\.)?wikipedia.org\/(((?!([\"'<])).)*)/m
str = 'https://en.m.wikipedia.org/wiki/DNS_over_TLS
https://en.wikipedia.org/wiki/DNS_over_TLS
en.m.wikipedia.org/wiki/DNS_over_TLS
en.wikipedia.org/wiki/DNS_over_TLS'
subst = 'wikiless.org/$2&lang=$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result