const regex = new RegExp('([\\w_-]+)\\.(?:m\\.)?wikipedia.org/(((?!([\\"\\'<])).)*)', 'gm')
const str = `https://en.m.wikipedia.org/wiki/DNS_over_TLS
https://en.wikipedia.org/wiki/DNS_over_TLS
en.m.wikipedia.org/wiki/DNS_over_TLS
en.wikipedia.org/wiki/DNS_over_TLS`;
const subst = `wikiless.org/$2&lang=$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);