package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+\.?\d+).*?(\d+,?\d+).*?(\d+,\d+)?.*$`)
var str = `25% on $53,501 to N $78,100.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}