$re = '/^(\d+\.?\d+).*?(\d+,?\d+).*?(\d+,\d+)?.*$/m';
$str = '25% on $53,501 to N $78,100.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);