re = /^(\d+\.?\d+).*?(\d+,?\d+).*?(\d+,\d+)?.*$/m
str = '25% on $53,501 to N $78,100.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end