const regex = /\bfloor area:?\s*(\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bfloor area:?\\s*(\\d+)', 'g')
const str = `A beautiful flat on the 3rd floor with floor area: 50 sqm and a lift
Newbuild flat. Floor Area: 30 sq.m","6 bed house with floor area 50 sqm, lot area 25 sqm
6 bed house with floor area 50 sqm, lot area 25 sqm`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}