import re
regex = re.compile(r"\bfloor area:?\s*(\d+)")
test_str = ("A beautiful flat on the 3rd floor with floor area: 50 sqm and a lift\n"
"Newbuild flat. Floor Area: 30 sq.m\",\"6 bed house with floor area 50 sqm, lot area 25 sqm\n"
"6 bed house with floor area 50 sqm, lot area 25 sqm")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")