using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!COM|\d)\d{11,19}(?!\d)";
string input = @"А23123132323B 123 BBB123123123DDD СЧ 80060050044, COM231231231231 80060050044 BBB123123123DDD 333";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}