const regex = /(?<!COM|\d)\d{11,19}(?!\d)/gui;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!COM|\\d)\\d{11,19}(?!\\d)', 'gui')
const str = `А23123132323B 123 BBB123123123DDD СЧ 80060050044, COM231231231231 80060050044 BBB123123123DDD 333`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}