use strict;
my $str = 'А23123132323B 123 BBB123123123DDD СЧ 80060050044, COM231231231231 80060050044 BBB123123123DDD 333';
my $regex = qr/(?<!COM|\d)\d{11,19}(?!\d)/uip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}