#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[\s:]|\d+(?:-|.)|^)\(?(\d{3})\)?(?:%20)*(?:[- .]+(?:%20)*)?(\d{3})(?:(?:%20)*[- .]*(?:%20)*)?(\d{4})(?=<|\s|$)"
Local $sString = "https://someresource.com/tel:(904)640%20%20-8301" & @CRLF & _
"https://someresource.com/tel:(904)%20640%208301" & @CRLF & _
"https://someresource.com/tel:(904)%20640-8301" & @CRLF & _
"https://someresource.com/tel:(904)%20640 - 8301" & @CRLF & _
"https://someresource.com/tel:(904)%20640%20-%208301"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")