import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[\\s:]|\\d+(?:-|.)|^)\\(?(\\d{3})\\)?(?:%20)*(?:[- .]+(?:%20)*)?(\\d{3})(?:(?:%20)*[- .]*(?:%20)*)?(\\d{4})(?=<|\\s|$)";
final String string = "https://someresource.com/tel:(904)640%20%20-8301\n"
+ "https://someresource.com/tel:(904)%20640%208301\n"
+ "https://someresource.com/tel:(904)%20640-8301\n"
+ "https://someresource.com/tel:(904)%20640 - 8301\n"
+ "https://someresource.com/tel:(904)%20640%20-%208301";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}