use strict;
my $str = 'https://someresource.com/tel:(904)640%20%20-8301
https://someresource.com/tel:(904)%20640%208301
https://someresource.com/tel:(904)%20640-8301
https://someresource.com/tel:(904)%20640 - 8301
https://someresource.com/tel:(904)%20640%20-%208301';
my $regex = qr/(?:[\s:]|\d+(?:-|.)|^)\(?(\d{3})\)?(?:%20)*(?:[- .]+(?:%20)*)?(\d{3})(?:(?:%20)*[- .]*(?:%20)*)?(\d{4})(?=<|\s|$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}