$re = '/[\r\n]{2}((?:[\s\S](?!\n\n))+(?![\s\S]))/im';
$str = 'Машина
текст текст текст
Кот
текст
динамический текст еще
Кот
текст
еще динамический текст';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);