import re
regex = re.compile(r"[\r\n]{2}((?:[\s\S](?!\n\n))+(?![\s\S]))", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("Машина\n"
"текст текст текст\n\n"
"Кот\n"
"текст\n"
"динамический текст еще\n\n"
"Кот\n"
"текст \n"
"еще динамический текст")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")