re = /[\r\n]{2}((?:[\s\S](?!\n\n))+(?![\s\S]))/im
str = 'Машина
текст текст текст
Кот
текст
динамический текст еще
Кот
текст
еще динамический текст'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end