package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)[^,]*микрорайон*[^,]`)
var str = `Забайкальский край, Чита, пяты северный микрорайон, Забайкальский край, Чита, р-н Центральный, мкр северный, улица Бабушкина, 99к1`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}