const regex = /[^,]*микрорайон*[^,]/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^,]*микрорайон*[^,]', 's')
const str = `Забайкальский край, Чита, пяты северный микрорайон, Забайкальский край, Чита, р-н Центральный, мкр северный, улица Бабушкина, 99к1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}