$re = '/[^,]*микрорайон*[^,]/s';
$str = 'Забайкальский край, Чита, пяты северный микрорайон, Забайкальский край, Чита, р-н Центральный, мкр северный, улица Бабушкина, 99к1';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);