import re
regex = re.compile(r"^(([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\.){3}([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])$", flags=re.MULTILINE)
test_str = ("102.242.234.121\n"
"243.171.221.0\n"
"243.171.221.0.0\n"
"170.132.134.555\n"
"000.000.000.000\n"
"195.103.67.52\n"
"110.128.244.14\n"
"243.221.0\n\n"
"// You can show origina post on albertcolom.com/blog")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")