const regex = /^(?!.*[^\na-z0-9]{2})(?=.*[a-z0-9]$)[a-z0-9].*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*[^\\na-z0-9]{2})(?=.*[a-z0-9]$)[a-z0-9].*$', 'gmi')
const str = `y
ye
yes
yesgood
yesgood
not-
ALSO_GOOD
not--good
NOT--GOOD
not!good
good
good-too
also_good
GOOD
GOOD-TOO
ALSO_GOOD
not--good
NOT--GOOD
not__good
NOT__GOOD
yes-good
yes_good
-NOTGOOD
-notgood
not!good
not#good
_not_good
-this-is-not-good-
_this_is_not_good_
_______this_is_not_good_________
not~good
yes-good
not-good!
yesgood
this!is?not=good
this-is-good
this_is_good
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}