import Foundation
let pattern = #"^(?!.*[^\na-z0-9]{2})(?=.*[a-z0-9]$)[a-z0-9].*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
y
ye
yes
yesgood
yesgood
not-
ALSO_GOOD
not--good
NOT--GOOD
not!good
good
good-too
also_good
GOOD
GOOD-TOO
ALSO_GOOD
not--good
NOT--GOOD
not__good
NOT__GOOD
yes-good
yes_good
-NOTGOOD
-notgood
not!good
not#good
_not_good
-this-is-not-good-
_this_is_not_good_
_______this_is_not_good_________
not~good
yes-good
not-good!
yesgood
this!is?not=good
this-is-good
this_is_good
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)