$re = '/^(?!.*[^\na-z0-9]{2})(?=.*[a-z0-9]$)[a-z0-9].*$/mi';
$str = 'y
ye
yes
yesgood
yesgood
not-
ALSO_GOOD
not--good
NOT--GOOD
not!good
good
good-too
also_good
GOOD
GOOD-TOO
ALSO_GOOD
not--good
NOT--GOOD
not__good
NOT__GOOD
yes-good
yes_good
-NOTGOOD
-notgood
not!good
not#good
_not_good
-this-is-not-good-
_this_is_not_good_
_______this_is_not_good_________
not~good
yes-good
not-good!
yesgood
this!is?not=good
this-is-good
this_is_good
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);