$re = '/(?<=v\\\\u003d)([a-zA-Z0-9-]*)/m';
$str = 'https://www.youtube.com/watch?v\\u003d-EMFXVcMWxo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);