const regex = /(\{color[^}]*\})|(\![^!]*(thumbnail)\!)|(^\|[\ \h]*)|(\|[\ ]*(?=[\n\r]))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\{color[^}]*\\})|(\\![^!]*(thumbnail)\\!)|(^\\|[\\ \\h]*)|(\\|[\\ ]*(?=[\\n\\r]))', 'gm')
const str = `"####  [MAINT-170 Setup a virtual IOS Development Environment](https://secure.spiria.com/jira-staging/browse/MAINT-170)####
**Description**
| |
| |
| |
|!https://www.pagerduty.com/wp-content/uploads/2016/05/pagerduty-logo-green.png!|[{color:#999999}shutterstock.pagerduty.com{color}|https://shutterstock.pagerduty.com/incidents]|
| |
| |
|Hello Don Ramsey, you have one open incident assigned to you:|
|{color:#767676}Incident #149053{color}|
| |
|[CRITICAL: 'check_renewal_tracking' on 'prod-worker16.ma01.bigstockcorp.net'|https://shutterstock.pagerduty.com/incidents/P4HX6H1]|
| |
|[{color:#333333}View Incident{color}|https://shutterstock.pagerduty.com/incidents/P4HX6H1]|
| |
|{color:#767676}Details{color}|
|pd_nagios_object: service CONTACTPAGER: 5bb546134cb64acb845ebdf05fc3ae6b|
| |
|{color:#767676}Status{color}|
|{color:#fc0f03}Triggered{color}|
| |
|{color:#767676}Urgency{color}|
|↑ High|
| |
|{color:#767676}Assigned To{color}|
|[{color:#005c9c}Don Ramsey{color}|https://shutterstock.pagerduty.com/users/PAHPTR7]|
| |
|{color:#767676}Opened On{color}|
|[{color:#000000}Oct 24, 2017 at 11:03 AM (Eastern Time (US & Canada)) {color}\\|]|
| |
|{color:#767676}Service{color}|
|[{color:#005c9c}nagios (Bigstock){color}|https://shutterstock.pagerduty.com/services/PVF3TQU]|
| |
|{color:#767676}Escalation Policy{color}|
|[{color:#005c9c}Bigstock Team Escalation{color}|https://shutterstock.pagerduty.com/escalation_policies#PYK0IBT]|
| |
| |
|You can disable these messages (or turn off HTML emails) by adjusting [{color:#005c9c}your notification rules{color}|https://shutterstock.pagerduty.com/users/PAHPTR7].|
| | |
| |
|{color:#767676}PagerDuty, Inc., 600 Townsend St., #200, San Francisco, California, 94103 Copyright © 2008 — 2017 PagerDuty, Inc. All rights reserved.{color}|
| |
"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}