import re
regex = re.compile(r"(\{color[^}]*\})|(\![^!]*(thumbnail)\!)|(^\|[\ \h]*)|(\|[\ ]*(?=[\n\r]))", flags=re.MULTILINE)
test_str = ("\"####  [MAINT-170 Setup a virtual IOS Development Environment](https://secure.spiria.com/jira-staging/browse/MAINT-170)####\n"
" **Description** \n"
"| |\n"
"| |\n"
"| |\n"
"|!https://www.pagerduty.com/wp-content/uploads/2016/05/pagerduty-logo-green.png!|[{color:#999999}shutterstock.pagerduty.com{color}|https://shutterstock.pagerduty.com/incidents]|\n"
"| |\n"
"| |\n"
"|Hello Don Ramsey, you have one open incident assigned to you:|\n"
" \n"
"|{color:#767676}Incident #149053{color}|\n"
"| |\n"
"|[CRITICAL: 'check_renewal_tracking' on 'prod-worker16.ma01.bigstockcorp.net'|https://shutterstock.pagerduty.com/incidents/P4HX6H1]|\n"
"| |\n"
"|[{color:#333333}View Incident{color}|https://shutterstock.pagerduty.com/incidents/P4HX6H1]|\n"
"| |\n"
"|{color:#767676}Details{color}|\n"
"|pd_nagios_object: service CONTACTPAGER: 5bb546134cb64acb845ebdf05fc3ae6b|\n"
"| |\n"
"|{color:#767676}Status{color}|\n"
"|{color:#fc0f03}Triggered{color}|\n"
"| |\n"
"|{color:#767676}Urgency{color}|\n"
"|↑ High|\n"
"| |\n"
"|{color:#767676}Assigned To{color}|\n"
"|[{color:#005c9c}Don Ramsey{color}|https://shutterstock.pagerduty.com/users/PAHPTR7]|\n"
"| |\n"
"|{color:#767676}Opened On{color}|\n"
"|[{color:#000000}Oct 24, 2017 at 11:03 AM (Eastern Time (US & Canada)) {color}\\|]|\n"
"| |\n"
"|{color:#767676}Service{color}|\n"
"|[{color:#005c9c}nagios (Bigstock){color}|https://shutterstock.pagerduty.com/services/PVF3TQU]|\n"
"| |\n"
"|{color:#767676}Escalation Policy{color}|\n"
"|[{color:#005c9c}Bigstock Team Escalation{color}|https://shutterstock.pagerduty.com/escalation_policies#PYK0IBT]|\n"
"| |\n"
"| |\n"
"|You can disable these messages (or turn off HTML emails) by adjusting [{color:#005c9c}your notification rules{color}|https://shutterstock.pagerduty.com/users/PAHPTR7].|\n"
"| | |\n"
"| |\n"
"|{color:#767676}PagerDuty, Inc., 600 Townsend St., #200, San Francisco, California, 94103 Copyright © 2008 — 2017 PagerDuty, Inc. All rights reserved.{color}|\n"
"| |\n\n"
" \"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")