#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx) ^ (?:31([-\/.\x20])(?:0?[13578]|1[02])\1|(?:29|30)([-\/])(?:0?[13-9]|1[0-2])\2)" & @CRLF & _
" (?:1[6-9]|[2-9]\d)?\d{2} " & @CRLF & _
" $" & @CRLF & _
"|" & @CRLF & _
" ^" & @CRLF & _
" 29([-\/])0?2\3" & @CRLF & _
" (?:" & @CRLF & _
" (?:1[6-9]|[2-9]\d)?" & @CRLF & _
" (?:0[48]|[2468][048]|[13579][26])" & @CRLF & _
" |" & @CRLF & _
" (?:16|[2468][048]|[3579][26])00)$" & @CRLF & _
"|" & @CRLF & _
" ^" & @CRLF & _
" (?:0?[1-9]|1\d|2[0-8])([-\/])(?:0?[1-9]|1[0-2])\4(?:1[6-9]|[2-9]\d)?\d{2}" & @CRLF & _
" $"
Local $sString = "30/,/1601" & @CRLF & _
"20/01/2011" & @CRLF & _
"19/09/2017" & @CRLF & _
"20/01/1601" & @CRLF & _
"28/,/1600"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")