$re = '/ ^ (?:31([-\/.\x20])(?:0?[13578]|1[02])\1|(?:29|30)([-\/])(?:0?[13-9]|1[0-2])\2)
(?:1[6-9]|[2-9]\d)?\d{2}
$
|
^
29([-\/])0?2\3
(?:
(?:1[6-9]|[2-9]\d)?
(?:0[48]|[2468][048]|[13579][26])
|
(?:16|[2468][048]|[3579][26])00)$
|
^
(?:0?[1-9]|1\d|2[0-8])([-\/])(?:0?[1-9]|1[0-2])\4(?:1[6-9]|[2-9]\d)?\d{2}
$/mx';
$str = '30/,/1601
20/01/2011
19/09/2017
20/01/1601
28/,/1600';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);