import re
regex = re.compile(r"""
^ (?:31([-\/.\x20])(?:0?[13578]|1[02])\1|(?:29|30)([-\/])(?:0?[13-9]|1[0-2])\2)
(?:1[6-9]|[2-9]\d)?\d{2}
$
|
^
29([-\/])0?2\3
(?:
(?:1[6-9]|[2-9]\d)?
(?:0[48]|[2468][048]|[13579][26])
|
(?:16|[2468][048]|[3579][26])00)$
|
^
(?:0?[1-9]|1\d|2[0-8])([-\/])(?:0?[1-9]|1[0-2])\4(?:1[6-9]|[2-9]\d)?\d{2}
$
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("30/,/1601\n"
"20/01/2011\n"
"19/09/2017\n"
"20/01/1601\n"
"28/,/1600")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")