package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\?&]([^=]+)\=([^&]+)`)
var str = `/test/test123/e/account/data/element?bUnit=17&name=cId&formName=TestForm&value=[self]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}