re = /[\?&]([^=]+)\=([^&]+)/m
str = '/test/test123/e/account/data/element?bUnit=17&name=cId&formName=TestForm&value=[self]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end