$re = '/[\?&]([^=]+)\=([^&]+)/m';
$str = '/test/test123/e/account/data/element?bUnit=17&name=cId&formName=TestForm&value=[self]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);