$re = '/\w+\[([^][]+|(?R))(?:,\s*((?1)))+\]/m';
$str = 'Tuple[Union[file.File, directory.Directory, Tuple[file.File, directory.Directory]], Tuple[file.File, directory.Directory]]
Tuple[int,int]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);