re = /\w+\[([^][]+|(?R))(?:,\s*((?1)))+\]/m
str = 'Tuple[Union[file.File, directory.Directory, Tuple[file.File, directory.Directory]], Tuple[file.File, directory.Directory]]
Tuple[int,int]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end