#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^\s*background:\s*)(?!\b(?:none|transparent)\b)[a-z]+;"
Local $sString = "background: #fff;" & @CRLF & _
"background: transparent;" & @CRLF & _
"background: none;" & @CRLF & _
"// background: blue;" & @CRLF & _
"background: blue;" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")