$re = '/(^\s*background:\s*)(?!\b(?:none|transparent)\b)[a-z]+;/m';
$str = 'background: #fff;
background: transparent;
background: none;
// background: blue;
background: blue;
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);