using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\s*background:\s*)(?!\b(?:none|transparent)\b)[a-z]+;";
string input = @"background: #fff;
background: transparent;
background: none;
// background: blue;
background: blue;
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}