import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Invoice Nr\\.?\\s*(?<arvenumber>[^\\W_]+)[\\s_]";
final String string = "...\n"
+ "Some nr_11687767_ other 101308591\n"
+ "Invoice Nr.\n"
+ "M230714_some text\n"
+ "Kirjeldus\n"
+ "...\n"
+ "Sometimes it is terminated by newline\n\n"
+ "...\n"
+ "This nr_11687767_KMKR_EE101308591\n"
+ "Invoice Nr.\n"
+ "M230714\n"
+ "01.05.2023\n"
+ "Item\n"
+ "...\n"
+ "or by other white space delimiter :\n\n"
+ "...\n"
+ "Some nr_11687767_ Text\n"
+ "Invoice Nr M230714 Date 01.05.2023\n"
+ "Desc\n"
+ "...";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}